Download links for Catalog files are failing for some users
Incident Report for Salsify
Resolved
The incident concerning Catalog Download Links has been resolved.

Please reach out to customer support at https://help.salsify.com/help/contact-feedback for any questions regarding this subject.
Posted Jun 25, 2024 - 13:45 EDT
Monitoring
We have implemented a fix to allow for Catalog download requests to complete as expected. We are monitoring for any change in behavior.
Please reach out to customer support at https://help.salsify.com/help/contact-feedback for any questions regarding this subject.
Posted Jun 25, 2024 - 12:42 EDT
Investigating
We have received reports that some users are experiencing an unexpected redirect when attempting to download files requested from Catalogs. We are actively investigating this issue.

Please reach out to customer support at https://help.salsify.com/help/contact-feedback for any questions regarding this subject.
Posted Jun 25, 2024 - 11:45 EDT
This incident affected: Salsify Application (Catalog Sites).