The incident with our partner, temporarily preventing users from uploading digital assets via file upload and from source URLs, has been resolved, and full functionality has been restored. Digital asset uploads are now fully operational. The temporary workaround (using the digital asset import functionality) is no longer necessary.
If you continue to experience any issues, please use the "My Cases" option within the Customer Portal (https://help.salsify.com/ProductXM/s/) to connect with our team.
Posted Jul 03, 2025 - 08:25 EDT
Update
The incident with our partner, temporarily preventing users from uploading digital assets via file upload and from source URLs, has been resolved, and full functionality has been restored. Digital asset uploads are now fully operational. The temporary workaround (using the digital asset import functionality) is no longer necessary.
If you continue to experience any issues, please use the "My Cases" option within the Customer Portal (https://help.salsify.com/ProductXM/s/) to connect with our team.
Posted Jul 03, 2025 - 08:24 EDT
Identified
Our engineering team as identified an issue that is currently preventing users from uploading digital assets, both via file upload and from source URLs. The issue is related to an incident experienced by the partner we work with to manage Salsify users' Digital Assets. As a temporary workaround, please use the digital asset import functionality. We will provide an update as soon as more information becomes available.
If you have any questions, please use the "My Cases" option within the Customer Portal (https://help.salsify.com/ProductXM/s/) to connect with our team.
Posted Jul 03, 2025 - 08:08 EDT
Investigating
Our engineering team is investigating an issue that is currently preventing users from uploading digital assets, both via file upload and from source URLs. As a temporary workaround, please use the digital asset import functionality. Our team is working to identify the root cause and will provide an update as soon as more information becomes available.
If you have any questions, please use the "My Cases" option within the Customer Portal (https://help.salsify.com/ProductXM/s/) to connect with our team.
Posted Jul 03, 2025 - 07:46 EDT
This incident affected: Salsify Application (Salsify Application).