Performance issues when accessing Salsify's Support Portal and Premium Support Live Chat

Incident Report for Salsify

Resolved

This incident has been resolved.
Posted Aug 19, 2021 - 16:28 EDT

Monitoring

We have seen improved performance when accessing our Support Portal and using Live Chat. We will continue to monitor and review any new reports of performance issues.
Posted Aug 19, 2021 - 15:29 EDT

Identified

Due to an ongoing performance issue with a vendor, some functionality on Salsify's Support Portal may be running at less than optimal performance. Some customers may experience intermittent slow performance, timeouts, and connectivity issues when viewing cases via our Support Portal or accessing Premium Support Live Chat. Our team is continuing to watch the situation closely. Updates to follow.
Posted Aug 19, 2021 - 10:29 EDT
This incident affected: Salsify Support Portal.