Automated processing of Salsify FTP files failing

Incident Report for Salsify

Resolved

Our engineering team has deployed a fix to the issue blocking specific FTP file(s) from being processed by our internal automation framework. Files that are using this specific internal automation framework will now process without any issues. Files specified for our internal automation that have been replaced within the Salsify FTP before 2025-08-30 1:00 AM UTC will not be processed.

Re-uploading the files into the Salsify FTP will allow our internal automation to process these files. When re-uploading these files, please allow a few minutes between uploads to give our automation time to process the file(s).

Please reach out to customer support at https://help.salsify.com/ProductXM/s/ for any questions regarding this subject.
Posted Aug 29, 2025 - 21:05 EDT

Investigating

We have received reports of an issue with the processing of certain files uploaded to the Salsify FTP, including some transformations, deliveries, and Salsify imports. A very limited set of files using a specific internal automation framework are affected.

All other functions in Salsify remain fully operational.

We are investigating this behavior and will provide an update as more information becomes available.

Please reach out to customer support at https://help.salsify.com/ProductXM/s/ for any questions regarding this subject.
Posted Aug 29, 2025 - 18:59 EDT
This incident affected: Salsify Application (Imports and Indexing, Salsify FTP).