Workflow tasks not loading for non-admin users
Incident Report for Salsify
Resolved
This issue has been resolved. Workflow tasks are loading as expected for all users.

Please reach out to support via https://help.salsify.com/help/contact-us with any questions or concerns.
Posted Jul 16, 2020 - 12:03 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 16, 2020 - 11:01 EDT
Identified
The team identified the root cause and are working toward a solution.
Posted Jul 16, 2020 - 10:03 EDT
Investigating
We are currently investigating an issue where workflow tasks are not loading for non-admin users.
Posted Jul 16, 2020 - 09:56 EDT
This incident affected: Salsify Application (Salsify Application).