Delays affecting imports, bulk edits, subscriptions

Incident Report for Salsify

Resolved

Our engineers identified and addressed an issue which caused long-queuing imports, as well as delayed bulk edit actions and subscription triggers. Operation times have returned to normal.

Please reach out to customer support at https://help.salsify.com/help/contact-feedback for any questions regarding this subject.
Posted Mar 04, 2026 - 14:31 EST

Monitoring

Our engineers have identified and addressed an issue which was causing long-queuing imports, as well as delayed bulk edit actions and subscription triggers. Operation times should be returning to normal. We are continuing to monitor closely.

Please reach out to customer support at https://help.salsify.com/help/contact-feedback for any questions regarding this subject.
Posted Mar 04, 2026 - 13:19 EST

Investigating

Our engineers are investigating long-queuing imports, and delayed bulk edit actions and subscription triggers.

Please reach out to customer support at https://help.salsify.com/help/contact-feedback for any questions regarding this subject.
Posted Mar 04, 2026 - 11:30 EST
This incident affected: Salsify Application (Salsify Application).