Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 15, 2026 - 16:00 EDT
Scheduled
To provide the best possible service to our users, Salsify will be performing maintenance starting at 4:00 PM EDT (8:00 PM GMT) on Friday, May 15th. This maintenance will allow us to continuously improve the platform and optimize the PIM experience. We expect to complete the maintenance within 2 hours. While the maintenance window is 2 hours, we expect the actual customer impact to be brief, lasting less than 2 minutes. During this brief period, users may experience:
• Temporary errors when logging in or navigating the application.
• Delays in search results or product filtering.
• Momentary delays in product changes reflecting in the UI.
For any failures or errors, we recommend refreshing your browser or retrying the action after a minute. For any questions, please use the "My Cases" option in the customer portal (https://help.salsify.com/ProductXM/s/) to contact our team.
Posted May 05, 2026 - 13:57 EDT
This scheduled maintenance affected: Syndication (Amazon, Walmart, GDSN, Syndication, 1WorldSync, The Home Depot, Open Catalog) and Salsify Application (Enhanced Content, Imports and Indexing, Insights, Salsify Application, Salsify CDN, Salsify FTP, Readiness Reports, Catalog Sites, Salsify Labs).