Live chat support service for Premium Support subscribers
Incident Report for Salsify
Resolved
Our third-party provider for live chat support service for Premium Support subscribers has informed us that this issue is now resolved.
Please reach out to customer support at https://help.salsify.com/help/contact-feedback for any questions regarding this subject.
Posted Dec 05, 2023 - 12:06 EST
Identified
We have been made aware that, due to performance issues impacting our third-party live chat support service for Premium Support subscribers is currently unavailable. While our partner implements a solution, please reach out to the Support Team using the "My Cases" option on our portal - https://help.salsify.com/ProductXM/s/. Our Support Team will follow up with you via the Case.
Posted Dec 04, 2023 - 17:04 EST
This incident affected: Salsify Support Portal.