Import and bulk edit slowness

Incident Report for Salsify

Resolved

An issue causing system slowness when completing imports and bulk updates was identified and the slowness has resolved.

Please reach out to customer support at https://support.salsify.com/ for any questions regarding this subject.
Posted Jun 04, 2025 - 11:49 EDT

Monitoring

The issue has been identified and slowness in completion of imports and bulk edits is resolving. Our engineers are continuing to monitor.

Please reach out to customer support at https://support.salsify.com/ for any questions regarding this subject.
Posted Jun 04, 2025 - 11:20 EDT

Investigating

Our engineers are currently investigating slowness in completion of imports and bulk edits.

Please reach out to customer support at https://support.salsify.com/ for any questions regarding this subject.
Posted Jun 04, 2025 - 10:57 EDT
This incident affected: Salsify Application (Imports and Indexing).