Slowness / delays when exporting and publishing data from Salsify

Incident Report for Salsify

Resolved

This incident has been resolved.
Posted Oct 16, 2025 - 17:21 EDT

Monitoring

Export and publication performance has returned to normal. Our engineers are continuing to monitor at this time.

Please reach out to customer support at https://help.salsify.com/ProductXM/s/ for any questions regarding this topic.
Posted Oct 15, 2025 - 16:57 EDT

Update

Our engineers are investigating issues with slowness when exporting or publishing from Salsify.

Please reach out to customer support at https://help.salsify.com/ProductXM/s/ for any questions regarding this topic.
Posted Oct 15, 2025 - 15:31 EDT

Investigating

Our engineers are investigating issues with slowness when exporting from Salsify.

Please reach out to customer support at https://help.salsify.com/ProductXM/s/ for any questions regarding this topic.
Posted Oct 15, 2025 - 15:15 EDT
This incident affected: Salsify Application (Salsify Application, Readiness Reports, Catalog Sites).