Salsify.com Not Loading, Please Use app.salsify.com to Log In
Incident Report for Salsify
Resolved
Salsify.com is now loading correctly. We'll investigate the root cause to ensure stability of the website. Please reach out if you're having trouble: https://help.salsify.com/help/contact-feedback
Posted about 1 month ago. Sep 19, 2019 - 08:36 EDT
Investigating
We are investigating a DNS issue with our marketing site salsify.com. The Salsify platform is unaffected. To log in please use app.salsify.com.
Posted about 1 month ago. Sep 19, 2019 - 05:41 EDT