Delays in Import runs, filtering and adding products to lists

Incident Report for Salsify

Resolved

We have confirmed that imports, product list additions, and filtering are all processing normally.

Please reach out to customer support at https://help.salsify.com/help/contact-feedback for any questions regarding this subject.
Posted Dec 09, 2025 - 12:03 EST

Monitoring

We have observed that import runs are now processing normally. Our engineering team continues to monitor the system to ensure all services—including product list additions and filtering—remain stable and fully operational.

Please reach out to customer support at https://help.salsify.com/help/contact-feedback for any questions regarding this subject.
Posted Dec 09, 2025 - 11:43 EST

Investigating

We are experiencing slowness in imports, adding products to smart and simple lists, and filtering for products using newly added property values. Our engineering team is investigating the issue causing the delays and queuing.

Please reach out to customer support at https://help.salsify.com/help/contact-feedback for any questions regarding this subject.
Posted Dec 09, 2025 - 11:10 EST
This incident affected: Salsify Application (Imports and Indexing).