Slowness across the Salsify Application

Incident Report for Salsify

Resolved

The platform has returned to a stable state.
Please reach out to customer support at https://help.salsify.com/help/contact-feedback for any questions regarding this subject.
Posted Feb 13, 2025 - 12:18 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 13, 2025 - 08:04 EST

Investigating

We are currently investigating this issue.
Posted Feb 13, 2025 - 06:27 EST

Monitoring

The Salsify Application is back to normal. We will continue to observe performance closely.
Posted Feb 13, 2025 - 04:23 EST

Investigating

We are currently investigating this issue.
Posted Feb 13, 2025 - 03:39 EST

Identified

The issue has been identified and a fix is being implemented.
Posted Feb 13, 2025 - 03:31 EST

Investigating

Our engineering team has identified an issue causing slowness across multiple areas of the Salsify Application.

We are investigating this behaviour with urgency and will provide an update as soon as possible.

Please reach out to customer support at https://help.salsify.com/help/contact-feedback for any questions regarding this subject.
Posted Feb 13, 2025 - 01:11 EST
This incident affected: Salsify Application (Salsify Application).