Amazon Seller Central publications failing
Incident Report for Salsify
Resolved
We have resolved an issue that was causing Amazon Seller Central publications to fail. Any failed publications from the morning of 8/26/19 will need to be resubmitted.
Posted 26 days ago. Aug 26, 2019 - 13:13 EDT
Investigating
We are currently investigating an issue with Amazon Seller Central publications failing. We'll update you as soon as we know more.
Posted 26 days ago. Aug 26, 2019 - 11:10 EDT
This incident affected: Syndication (Amazon).