Digital asset uploads are delayed

Incident Report for Salsify

Resolved

Digital Asset upload functionality has returned to normal and this incident is now resolved.

If you have any questions, please use the "My Cases" option within the Customer Portal (https://help.salsify.com/ProductXM/s/) to connect with our team.
Posted Jul 03, 2025 - 14:31 EDT

Monitoring

We are experiencing delays in digital asset uploads due to an incident with our digital asset management partner. Our partner has indicated that a fix has been deployed. Our team is continuing to monitor the issue.

If you continue to experience any issues, please use the "My Cases" option within the Customer Portal (https://help.salsify.com/ProductXM/s/) to connect with our team.
Posted Jul 03, 2025 - 10:43 EDT
This incident affected: Salsify Application (Salsify Application).