Degraded filter experience

Incident Report for Salsify

Resolved

This incident has been resolved.

Please reach out to customer support at https://support.salsify.com/ for any questions regarding this subject.
Posted Apr 18, 2025 - 15:03 EDT

Monitoring

We have implemented a fix, correcting the filter experience. We will continue monitoring to ensure functionality remains stable.

Please reach out to customer support at https://support.salsify.com/ for any questions regarding this subject.
Posted Apr 16, 2025 - 16:23 EDT

Investigating

We have identified degraded filter experiences throughout the platform. Our engineers are actively investigating this issue.
Please reach out to customer support at https://support.salsify.com/ for any questions regarding this subject.
Posted Apr 16, 2025 - 12:41 EDT
This incident affected: Salsify Application (Salsify Application).