Salsify FTP connection failures

Incident Report for Salsify

Resolved

Through our monitoring, we have seen stable connections to the Salsify FTP since March 2, 2026 at 9:30PM UTC. Publication to the Salsify FTP and imports of files from the Salsify FTP are completing successfully without any issues.

Please reach out to customer support at https://help.salsify.com/help/contact-feedback for any questions regarding this subject.
Posted Mar 06, 2026 - 11:58 EST

Monitoring

On March 2, 2026 at approximately 9:00PM UTC, multiple connection failures occurred when processing imports from and exports to the Salsify FTP. The connection errors appear to be resolved as of 9:30PM UTC. We are continuing to monitor the imports and exports connecting to the Salsify FTP to ensure this does not occur again.
Please reach out to customer support at https://help.salsify.com/help/contact-feedback for any questions regarding this subject.
Posted Mar 02, 2026 - 17:28 EST
This incident affected: Salsify Application (Salsify FTP).