Some users are unable to access the Product Details Page
Incident Report for Salsify
Resolved
We have resolved the issue and users are now able to view the Product Details Page on Microsoft Edge. If you continue to experience issues or have any questions, please reach out to our Customer Support team at support.salsify.com.
Posted 20 days ago. Oct 02, 2019 - 15:53 EDT
Identified
We have identified the issue and are working on implementing a fix. The issue is affecting users who are viewing any products on Microsoft Edge. As a temporary workaround, we recommend using an alternative browser.
Posted 20 days ago. Oct 02, 2019 - 15:08 EDT
Investigating
We are currently investigating reports that some customers are unable to access the Product Details page for some products. Our team is looking into the issue with urgency. We'll follow up with updates as they become available.
Posted 20 days ago. Oct 02, 2019 - 14:29 EDT
This incident affected: Salsify Application (Salsify Application).