Salsify's Support Portal (support.salsify.com) is currently unavailable
Incident Report for Salsify
Resolved
The issue is now resolved and users should be able to access Salsify's Support Portal (support.salsify.com). If you come across any issues accessing the Support Portal, please reach out to our team via email at support@salsify.com.
Posted about 1 month ago. Sep 16, 2019 - 15:38 EDT
Identified
Due to a performance issue with an upstream provider, Salsify's Support Portal (support.salsify.com) is currently unavailable. For any urgent issues, please email our team at support@salsify.com.
Posted about 1 month ago. Sep 16, 2019 - 15:08 EDT
This incident affected: Salsify Support Portal.