Salsify application is currently unavailable
Incident Report for Salsify
Resolved
The issue is now resolved and everything is back up and operational.
Please email support@salsify.com if you experience any issue. Thanks!
Posted 6 months ago. Jun 16, 2018 - 16:31 EDT
Investigating
The Salsify application is currently unavailable. Our DNS provider is currently experiencing an issue. We're investigating the situation and we will provide an update as soon as we know more.
Posted 6 months ago. Jun 16, 2018 - 16:14 EDT
This incident affected: Salsify Application.