Salsify Support Portal and Knowledge Base website not loading
Incident Report for Salsify
Resolved
The issue causing our Salsify Support Portal and Knowledge Base (https://help.salsify.com) to not load has been addressed, and the website is now working as expected.
Posted Mar 24, 2021 - 10:28 EDT
Investigating
Our engineering team is currently investigating an issue that is causing our Salsify Support Portal and Knowledge Base (https://help.salsify.com)  to not load. We hope to have this resolved as soon as possible. Please reach out to customer support via email to support@salsify.com for any questions regarding this subject.
Posted Mar 24, 2021 - 07:58 EDT
This incident affected: Salsify Support Portal.