Salsify Support Portal and Knowledgebase Experiencing Issues
Incident Report for Salsify
Resolved
The issue causing our Salsify Support Portal and Knowledge Base (https://help.salsify.com) to not load has been addressed. As of 7pm ET on Tuesday March 30th, the website was working as expected and any cases submitted via the form were received.
Posted Mar 31, 2021 - 07:12 EDT
Investigating
Our engineering team is currently investigating an issue that is causing our Salsify Support Portal and Knowledge Base (https://help.salsify.com) to not load. We hope to have this resolved as soon as possible. Please reach out to customer support via email to support@salsify.com for any questions regarding this subject.
Posted Mar 30, 2021 - 17:52 EDT
This incident affected: Salsify Support Portal.