Issue Loading Digital Assets in Tasks
Incident Report for Salsify
Resolved
Please reach out to customer support at https://help.salsify.com/help/contact-feedback for any questions regarding this subject.
Posted Apr 18, 2024 - 17:56 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Apr 18, 2024 - 14:19 EDT
Investigating
We have identified an issue with users loading digital assets
Posted Apr 18, 2024 - 13:42 EDT
This incident affected: Salsify Application (Salsify Application).